Skip to main content
← All vulnerabilities
CVE-2019-1611

Cisco FXOS and NX-OS Software CLI Command Injection Vulnerability (CVE-2019-1611)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.2.91, 2.3.1.110, 2.4.1.222, 6.2(25), 8.3(1), and 8 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

A vulnerability in the CLI of Cisco NX-OS Software and Cisco FXOS Software could allow an authenticated, local attacker to execute arbitrary commands on the underlying operating system of an affected device. The vulnerability is due to insufficient validation of arguments passed to certain CLI commands. An attacker could exploit this vulnerability by including malicious input as the argument of an affected command. A successful exploit could allow the attacker to execute arbitrary commands on the underlying operating system with elevated privileges. An attacker would need valid administrator credentials to exploit this vulnerability. Firepower 4100 Series Next-Generation Firewalls are affected running software versions prior to 2.2.2.91, 2.3.1.110, and 2.4.1.222. Firepower 9300 Security Appliance are affected running software versions prior to 2.2.2.91, 2.3.1.110, and 2.4.1.222. MDS 9000 Series Multilayer Switches are affected running software versions prior to 6.2(25) and 8.3(1). Nexus 3000 Series Switches are affected running software versions prior to 7.0(3)I4(9) and 7.0(3)I7(5). Nexus 3500 Platform Switches are affected running software versions prior to 7.0(3)I7(5). Nexus 3600 Platform Switches are affected running software versions prior to 7.0(3)F3(5). Nexus 2000, 5500, 5600, and 6000 Series Switches are affected running software versions prior to 7.1(5)N1(1b) and 7.3(4)N1(1). Nexus 7000 and 7700 Series Switches are affected running software versions prior to 6.2(22), 7.3(3)D1(1), 8.2(3). Nexus 9000 Series Switches in Standalone NX-OS Mode are affected running software versions prior to 7.0(3)I4(9) and 7.0(3)I7(5). Nexus 9500 R-Series Line Cards and Fabric Modules are affected running software versions prior to 7.0(3)F3(5).

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Cisco Firepower 4100 Series Next-Generation Firewalls

    fixed in 2.2.2.91; fixed in 2.3.1.110; fixed in 2.4.1.222

  • Cisco Firepower 9300 Security Appliance

    fixed in 2.2.2.91; fixed in 2.3.1.110; fixed in 2.4.1.222

  • Cisco MDS 9000 Series Multilayer Switches

    fixed in 6.2(25); fixed in 8.3(1)

  • Cisco Nexus 3000 Series Switches

    fixed in 7.0(3)I4(9); fixed in 7.0(3)I7(5)

  • Cisco Nexus 3500 Platform Switches

    fixed in 7.0(3)I7(5)

  • Cisco Nexus 3600 Platform Switches

    fixed in 7.0(3)F3(5)

  • Cisco Nexus 2000, 5500, 5600, and 6000 Series Switches

    fixed in 7.1(5)N1(1b); fixed in 7.3(4)N1(1)

  • Cisco Nexus 7000 and 7700 Series Switches

    fixed in 6.2(22); fixed in 7.3(3)D1(1); fixed in 8.2(3)

  • Cisco Nexus 9000 Series Switches in Standalone NX-OS Mode

    fixed in 7.0(3)I4(9); fixed in 7.0(3)I7(5)

  • Cisco Nexus 9500 R-Series Line Cards and Fabric Modules

    fixed in 7.0(3)F3(5)

References 2

securityfocus.com

tools.cisco.com