Skip to main content
← All vulnerabilities
CVE-2019-15795GHSA-RP8M-H266-53JH

python-apt uses MD5 for validation

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.8.3ubuntu7.5, 0.9.3.5ubuntu3+esm2, 1.1.0~beta1ubuntu0.16.04.7, 1.6.5ubuntu0.1, 1.9.0ubuntu1.2, and 2 more
None on Exploit-DB, Metasploit or GitHub

Summary

python-apt only checks the MD5 sums of downloaded files in `Version.fetch_binary()` and `Version.fetch_source()` of apt/package.py in version 1.9.0ubuntu1 and earlier. This allows a man-in-the-middle attack which could potentially be used to install altered packages and has been fixed in versions 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Canonical Python-apt

    From 0.8.3 · fixed in 0.8.3ubuntu7.5; From 0.9.3.5 · fixed in 0.9.3.5ubuntu3+esm2; From 1.1.0 · fixed in 1.1.0~beta1ubuntu0.16.04.7; From 1.6.5 · fixed in 1.6.5ubuntu0.1; From 1.9.0 · fixed in 1.9.0ubuntu1.2

  • python-aptPyPI

    fixed in 0.8.3ubuntu7.5

  • python-aptPyPI

    From 0.9.0 · fixed in 0.9.3.5ubuntu3

  • python-aptPyPI

    From 1.0.0 · fixed in 1.1.0

  • python-aptPyPI

    From 1.2.0 · fixed in 1.6.5ubuntu0.1

  • python-aptPyPI

    From 1.7.0 · fixed in 1.9.0ubuntu1.2

References 2

usn.ubuntu.com