CVE-2019-14905PYSEC-2020-206GHSA-FRXJ-5J27-F8RF
A vulnerability was found in Ansible Engine versions 2.9.x before 2.9.3, 2.8.x before 2.8.8, 2.7.x before 2.7.16 and earlier, where in Ansib
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.7.16, 2.8.8, 2.9.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A vulnerability was found in Ansible Engine versions 2.9.x before 2.9.3, 2.8.x before 2.8.8, 2.7.x before 2.7.16 and earlier, where in Ansible's nxos_file_copy module can be used to copy files to a flash or bootflash on NXOS devices. Malicious code could craft the filename parameter to perform OS command injections. This could result in a loss of confidentiality of the system among other issues.
Timeline
- CVE published
- Record last updated
Affected versions
- Red Hat Ansible
2.9.x before 2.9.3, 2.8.x before 2.8.8, 2.7.x before 2.7.16
- ansiblePyPI
From 2.7.0 · fixed in 2.7.16; From 2.8.0 · fixed in 2.8.8; From 2.9.0 · fixed in 2.9.3
- ansiblePyPI
From 2.7.0a1 · fixed in 2.7.16
- ansiblePyPI
From 2.8.0a1 · fixed in 2.8.8
- ansiblePyPI
From 2.9.0a1 · fixed in 2.9.3