Skip to main content
← All vulnerabilities
CVE-2019-14880GHSA-RV62-6F56-J83W

A vulnerability was found in Moodle versions 3.7 before 3.7.3, 3.6 before 3.6.7, 3.5 before 3.5.9 and earlier.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.7.3, 3.6.7, 3.5.9
None on Exploit-DB, Metasploit or GitHub

Summary

A vulnerability was found in Moodle versions 3.7 before 3.7.3, 3.6 before 3.6.7, 3.5 before 3.5.9 and earlier. OAuth 2 providers who do not verify users' email address changes require additional verification during sign-up to reduce the risk of account compromise.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • [UNKNOWN] moodle

    3.7 before 3.7.3, 3.6 before 3.6.7, 3.5 before 3.5.9

  • moodle/moodlePackagist

    From 3.7.0 · fixed in 3.7.3

  • moodle/moodlePackagist

    From 3.6.0 · fixed in 3.6.7

  • moodle/moodlePackagist

    From 3.5.0 · fixed in 3.5.9

References 2

moodle.org

bugzilla.redhat.com