Skip to main content
← All vulnerabilities
CVE-2019-14879GHSA-G9M2-C2X5-FR2V

A vulnerability was found in Moodle versions 3.7.x before 3.7.3, 3.6.x before 3.6.7 and 3.5.x before 3.5.9.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.7.3, 3.6.7, 3.5.9
None on Exploit-DB, Metasploit or GitHub

Summary

A vulnerability was found in Moodle versions 3.7.x before 3.7.3, 3.6.x before 3.6.7 and 3.5.x before 3.5.9. When a cohort role assignment was removed, the associated capabilities were not being revoked (where applicable).

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • [UNKNOWN] moodle

    3.7.x before 3.7.3, 3.6.x before 3.6.7, 3.5.x before 3.5.9

  • moodle/moodlePackagist

    From 3.7.0 · fixed in 3.7.3

  • moodle/moodlePackagist

    From 3.6.0 · fixed in 3.6.7

  • moodle/moodlePackagist

    From 3.5.0 · fixed in 3.5.9

References 1

bugzilla.redhat.com