CVE-2019-14858PYSEC-2019-171GHSA-H653-95QW-H2MP
A vulnerability was found in Ansible engine 2.x up to 2.8 and Ansible tower 3.x up to 3.5.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.8.1, 2.9.0rc4, 2.8.6, 2.7.14, 2.6.20
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A vulnerability was found in Ansible engine 2.x up to 2.8 and Ansible tower 3.x up to 3.5. When a module has an argument_spec with sub parameters marked as no_log, passing an invalid parameter name to the module will cause the task to fail before the no_log options in the sub parameters are processed. As a result, data in the sub parameter fields will not be masked and will be displayed if Ansible is run with increased verbosity and present in the module invocation arguments for the task.
Timeline
- CVE published
- Record last updated
Affected versions
- Red Hat Ansible
ansible_engine-2.x up to 2.8, ansible_tower-3.x up to 3.5
- ansiblePyPI
From 2.0 · fixed in 2.8.1
- ansiblePyPI
From 2.9.0a1 · fixed in 2.9.0rc4
- ansiblePyPI
From 2.8.0a1 · fixed in 2.8.6
- ansiblePyPI
From 2.7.0a1 · fixed in 2.7.14
- ansiblePyPI
From 2.0 · fixed in 2.6.20