CVE-2019-14846PYSEC-2019-4GHSA-PM48-CVV2-29Q5
In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.6.20, 2.7.14, 2.8.6
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that logged credentials at the DEBUG level. This flaw does not affect Ansible modules, as those are executed in a separate process.
Timeline
- CVE published
- Record last updated
Affected versions
- Red Hat Ansible
Version range not reported
- ansiblePyPI
fixed in 2.6.20; From 2.7.0 · fixed in 2.7.14; From 2.8.0 · fixed in 2.8.6
- ansiblePyPI
fixed in 2.6.20
- ansiblePyPI
From 2.7.0a1 · fixed in 2.7.14
- ansiblePyPI
From 2.8.0a1 · fixed in 2.8.6