Skip to main content
← All vulnerabilities
CVE-2019-13209GO-2022-0755GHSA-XHG2-RVM8-W2JH

Rancher 2 through 2.2.4 is vulnerable to a Cross-Site Websocket Hijacking attack that allows an exploiter to gain access to clusters managed

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.5-rc6.0.20190621200032-0ddffe484adc+incompatible, 2.0.16, 2.1.11, 2.2.5
None on Exploit-DB, Metasploit or GitHub

Summary

Rancher 2 through 2.2.4 is vulnerable to a Cross-Site Websocket Hijacking attack that allows an exploiter to gain access to clusters managed by Rancher. The attack requires a victim to be logged into a Rancher server, and then to access a third-party site hosted by the exploiter. Once that is accomplished, the exploiter is able to execute commands against the cluster's Kubernetes API with the permissions and identity of the victim.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • github.com/rancher/rancherGo

    fixed in 2.2.5-rc6.0.20190621200032-0ddffe484adc+incompatible

  • github.com/rancher/rancherGo

    From 2.0.0 · fixed in 2.0.16

  • github.com/rancher/rancherGo

    From 2.1.0 · fixed in 2.1.11

  • github.com/rancher/rancherGo

    From 2.2.0 · fixed in 2.2.5

References 2

forums.rancher.com