Skip to main content
← All vulnerabilities
CVE-2019-12472GHSA-7MQG-5FGH-XH4R

An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.27.6, 1.30.2, 1.31.2, 1.32.2
None on Exploit-DB, Metasploit or GitHub

Summary

An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • mediawiki/corePackagist

    From 1.18.0 · fixed in 1.27.6

  • mediawiki/corePackagist

    From 1.30.0 · fixed in 1.30.2

  • mediawiki/corePackagist

    From 1.31.0 · fixed in 1.31.2

  • mediawiki/corePackagist

    From 1.32.0 · fixed in 1.32.2

References 2

phabricator.wikimedia.org

lists.wikimedia.org