CVE-2019-12471GHSA-2RM7-XXX8-35JH
Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.27.6, 1.30.2, 1.31.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- mediawiki/corePackagist
From 1.27.0 · fixed in 1.27.6
- mediawiki/corePackagist
From 1.30.0 · fixed in 1.30.2
- mediawiki/corePackagist
From 1.31.0 · fixed in 1.31.2