Skip to main content
← All vulnerabilities
CVE-2019-12468GHSA-WRHX-3PXR-6VGG

An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.27.0 through 1.32.1.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.27.6, 1.30.2, 1.31.2, 1.32.2
None on Exploit-DB, Metasploit or GitHub

Summary

An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.27.0 through 1.32.1. Directly POSTing to Special:ChangeEmail would allow for bypassing re-authentication, allowing for potential account takeover.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • mediawiki/corePackagist

    From 1.27.0 · fixed in 1.27.6

  • mediawiki/corePackagist

    From 1.30.0 · fixed in 1.30.2

  • mediawiki/corePackagist

    From 1.31.0 · fixed in 1.31.2

  • mediawiki/corePackagist

    From 1.32.0 · fixed in 1.32.2

References 5

lists.wikimedia.org

debian.org

seclists.org

phabricator.wikimedia.org