CVE-2019-12397GHSA-FPQP-V323-44XV
Policy import functionality in Apache Ranger 0.7.0 to 1.2.0 is vulnerable to a cross-site scripting issue.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.0.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Policy import functionality in Apache Ranger 0.7.0 to 1.2.0 is vulnerable to a cross-site scripting issue. Upgrade to 2.0.0 or later version of Apache Ranger with the fix.
Timeline
- CVE published
- Record last updated
Affected versions
- Apache Software Foundation Apache Ranger
0.7.0 to 1.2.0
- org.apache.ranger:rangerMaven
From 0.7.0 · fixed in 2.0.0
References 6
cwiki.apache.org
openwall.com
lists.apache.org
- thread.html/ab2de1adad96f5dbd19d976b28715dfc60dbe75e82a74f48be8ef695@<dev.ranger.apache.org>
- thread.html/cbc6346708ef2b9ffb2555637311bf6294923c609c029389fa39de8f@<dev.ranger.apache.org>
- thread.html/r04bc435a92911de4b52d2b98f169bd7cf2e8bbeb53b03788df8f932c@<dev.ranger.apache.org>
- thread.html/rd88077a781ef38f7687c100f93992f4dda8aa101925050c4af470998@<dev.ranger.apache.org>