Skip to main content
← All vulnerabilities
CVE-2019-12149GHSA-4J6V-3895-8G2J

SQL injection vulnerability in silverstripe/restfulserver module 1.0.x before 1.0.9, 2.0.x before 2.0.4, and 2.1.x before 2.1.2 and silverst

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.1.2, 2.1.1, 2.2.1, 1.0.9, 2.0.4
None on Exploit-DB, Metasploit or GitHub

Summary

SQL injection vulnerability in silverstripe/restfulserver module 1.0.x before 1.0.9, 2.0.x before 2.0.4, and 2.1.x before 2.1.2 and silverstripe/registry module 2.1.x before 2.1.1 and 2.2.x before 2.2.1 allows attackers to execute arbitrary SQL commands.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • silverstripe/restfulserverPackagist

    From 2.1.0 · fixed in 2.1.2

  • silverstripe/registryPackagist

    From 2.1.0 · fixed in 2.1.1

  • silverstripe/registryPackagist

    From 2.2.0 · fixed in 2.2.1

  • silverstripe/restfulserverPackagist

    From 1.0.0 · fixed in 1.0.9

  • silverstripe/restfulserverPackagist

    From 2.0.0 · fixed in 2.0.4

References 1

silverstripe.org