CVE-2019-11325GHSA-W4RC-RX25-8M86
An issue was discovered in Symfony before 4.2.12 and 4.3.x before 4.3.8.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 4.2.12, 4.3.8
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
An issue was discovered in Symfony before 4.2.12 and 4.3.x before 4.3.8. The VarExport component incorrectly escapes strings, allowing some specially crafted ones to escalate to execution of arbitrary PHP code. This is related to symfony/var-exporter.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- symfony/symfonyPackagist
From 4.2.0 · fixed in 4.2.12
- symfony/symfonyPackagist
From 4.3.0 · fixed in 4.3.8
- symfony/var-exporterPackagist
From 4.2.0 · fixed in 4.2.12
- symfony/var-exporterPackagist
From 4.3.0 · fixed in 4.3.8