CVE-2019-11291
RabbitMQ XSS attack via federation and shovel endpoints
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in v3.8.1, v3.7.20, 1.17.4, 1.16.7
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Pivotal RabbitMQ, 3.7 versions prior to v3.7.20 and 3.8 version prior to v3.8.1, and RabbitMQ for PCF, 1.16.x versions prior to 1.16.7 and 1.17.x versions prior to 1.17.4, contain two endpoints, federation and shovel, which do not properly sanitize user input. A remote authenticated malicious user with administrative access could craft a cross site scripting attack via the vhost or node name fields that could grant access to virtual hosts and policy management information.
Timeline
- CVE published
- Record last updated
Affected versions
- Pivotal RabbitMQ
From 3.8 · fixed in v3.8.1; From 3.7 · fixed in v3.7.20
- Pivotal RabbitMQ for Pivotal Platform
From 1.17 · fixed in 1.17.4; From 1.16 · fixed in 1.16.7