CVE-2019-11287
RabbitMQ Web Management Plugin DoS via heap overflow
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.16.7, 1.17.4, v3.7.21, v3.8.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub
Summary
Pivotal RabbitMQ, versions 3.7.x prior to 3.7.21 and 3.8.x prior to 3.8.1, and RabbitMQ for Pivotal Platform, 1.16.x versions prior to 1.16.7 and 1.17.x versions prior to 1.17.4, contain a web management plugin that is vulnerable to a denial of service attack. The "X-Reason" HTTP Header can be leveraged to insert a malicious Erlang format string that will expand and consume the heap, resulting in the server crashing.
Timeline
- CVE published
- Record last updated
Affected versions
- Pivotal RabbitMQ for Pivotal Platform
From 1.16 · fixed in 1.16.7; From 1.17 · fixed in 1.17.4
- Pivotal RabbitMQ
From 3.7 · fixed in v3.7.21; From 3.8 · fixed in v3.8.1