CVE-2019-11277
Volume Services is vulnerable to an LDAP injection attack
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in v1.7.11, v2.3.0, v11.1.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Cloud Foundry NFS Volume Service, 1.7.x versions prior to 1.7.11 and 2.x versions prior to 2.3.0, is vulnerable to LDAP injection. A remote authenticated malicious space developer can potentially inject LDAP filters via service instance creation, facilitating the malicious space developer to deny service or perform a dictionary attack.
Timeline
- CVE published
- Record last updated
Affected versions
- Cloud Foundry CF NFS volume release
From 1.7 · fixed in v1.7.11; From 2.3 · fixed in v2.3.0
- Cloud Foundry CF Deployment
fixed in v11.1.0