CVE-2019-11254GHSA-WXC4-F4M6-WWQVGO-2020-0036
Kubernetes API Server denial of service vulnerability from malicious YAML payloads
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.2.8
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The Kubernetes API Server component in versions 1.1-1.14, and versions prior to 1.15.10, 1.16.7 and 1.17.3 allows an authorized user who sends malicious YAML payloads to cause the kube-apiserver to consume excessive CPU cycles while parsing YAML.
Timeline
- CVE published
- Record last updated
Affected versions
- Kubernetes Kubernetes
prior to 1.15.10, prior to 1.16.7, prior to 1.17.3, 1.1, 1.2, 1.3, 1.4, 1.5, 1.6, 1.7, 1.8, 1.9, 1.10, 1.11, 1.12, 1.13, 1.14
- gopkg.in/yaml.v2Go
fixed in 2.2.8
- github.com/go-yaml/yamlGo
through 2.1.0
- github.com/go-yaml/yamlGo
All versions