Kubernetes API Server JSON/YAML parsing vulnerable to resource exhaustion attack
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.13.12, 1.14.8, 1.15.5, 1.16.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 Nuclei template
Summary
Improper input validation in the Kubernetes API server in versions v1.0-1.12 and versions prior to v1.13.12, v1.14.8, v1.15.5, and v1.16.2 allows authorized users to send malicious YAML or JSON payloads, causing the API server to consume excessive CPU or memory, potentially crashing and becoming unavailable. Prior to v1.14.0, default RBAC policy authorized anonymous users to submit requests that could trigger this vulnerability. Clusters upgraded from a version prior to v1.14.0 keep the more permissive policy by default for backwards compatibility.
Timeline
- CVE published
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Kubernetes Kubernetes
prior to 1.13.12, prior to 1.14.8, prior to 1.15.5, prior to 1.16.2, 1.1, 1.2, 1.3, 1.4, 1.5, 1.6, 1.7, 1.8, 1.9, 1.10, 1.11, 1.12
- k8s.io/kubernetesGo
From 1.0.0 · fixed in 1.13.12; From 1.14.0 · fixed in 1.14.8; From 1.15.0 · fixed in 1.15.5; From 1.16.0 · fixed in 1.16.2
- k8s.io/kubernetesGo
From 1.0.0 · fixed in 1.13.12
- k8s.io/kubernetesGo
From 1.14.0 · fixed in 1.14.8
- k8s.io/kubernetesGo
From 1.15.0 · fixed in 1.15.5
- k8s.io/kubernetesGo
From 1.16.0 · fixed in 1.16.2