Skip to main content
← All vulnerabilities
CVE-2019-11043

Underflow in PHP-FPM can lead to RCE

Published
Last modified
published
Listed in CISA KEV
Fix
Fixed in 7.1.33, 7.2.24, 7.3.11
None on Exploit-DB, Metasploit or GitHub

Summary

The vulnerability affects PHP, specifically its PHP-FPM (FastCGI Process Manager) module, in certain server configurations. An attacker could exploit a memory write past allocated buffers to potentially execute arbitrary code remotely on the affected server.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

In PHP versions 7.1.x below 7.1.33, 7.2.x below 7.2.24 and 7.3.x below 7.3.11 in certain configurations of FPM setup it is possible to cause FPM module to write past allocated buffers into the space reserved for FCGI protocol data, thus opening the possibility of remote code execution.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • PHP PHP

    From 7.1.x · fixed in 7.1.33; From 7.2.x · fixed in 7.2.24; From 7.3.x · fixed in 7.3.11

References 25

GitHub · neex/phuip-fpizdam

bugs.php.net

usn.ubuntu.com

debian.org

support.f5.com

lists.fedoraproject.org

security.netapp.com

access.redhat.com

lists.opensuse.org

synology.com

support.apple.com

seclists.org