Skip to main content
← All vulnerabilities
CVE-2019-10913GHSA-X92H-WMG2-6HP7

In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, HTTP Methods provided as verbs

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.51, 2.8.50, 3.4.26, 4.1.12, 4.2.7
None on Exploit-DB, Metasploit or GitHub

Summary

In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, HTTP Methods provided as verbs or using the override header may be treated as trusted input, but they are not validated, possibly causing SQL injection or XSS. This is related to symfony/http-foundation.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • symfony/http-foundationPackagist

    From 2.7.0 · fixed in 2.7.51

  • symfony/http-foundationPackagist

    From 2.8.0 · fixed in 2.8.50

  • symfony/http-foundationPackagist

    From 3.0.0 · fixed in 3.4.26

  • symfony/http-foundationPackagist

    From 4.0.0 · fixed in 4.1.12

  • symfony/http-foundationPackagist

    From 4.2.0 · fixed in 4.2.7

  • symfony/symfonyPackagist

    From 2.7.0 · fixed in 2.7.51

  • symfony/symfonyPackagist

    From 2.8.0 · fixed in 2.8.50

  • symfony/symfonyPackagist

    From 3.0.0 · fixed in 3.4.26

  • symfony/symfonyPackagist

    From 4.0.0 · fixed in 4.1.12

  • symfony/symfonyPackagist

    From 4.2.0 · fixed in 4.2.7

References 2

symfony.com

GitHub · symfony/symfony