CVE-2019-10911GHSA-CCHX-MFRC-FWQR
In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, a vulnerability would allow an
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.7.51, 2.8.50, 3.4.26, 4.1.12, 4.2.7
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, a vulnerability would allow an attacker to authenticate as a privileged user on sites with user registration and remember me login functionality enabled. This is related to symfony/security.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- symfony/security-httpPackagist
From 2.7.0 · fixed in 2.7.51
- symfony/security-httpPackagist
From 2.8.0 · fixed in 2.8.50
- symfony/security-httpPackagist
From 3.0.0 · fixed in 3.4.26
- symfony/security-httpPackagist
From 4.0.0 · fixed in 4.1.12
- symfony/security-httpPackagist
From 4.2.0 · fixed in 4.2.7
- symfony/securityPackagist
From 2.7.0 · fixed in 2.7.51
- symfony/securityPackagist
From 2.8.0 · fixed in 2.8.50
- symfony/securityPackagist
From 3.0.0 · fixed in 3.4.26
- symfony/securityPackagist
From 4.0.0 · fixed in 4.1.12
- symfony/securityPackagist
From 4.2.0 · fixed in 4.2.7
- symfony/symfonyPackagist
From 2.7.0 · fixed in 2.7.51
- symfony/symfonyPackagist
From 2.8.0 · fixed in 2.8.50
- symfony/symfonyPackagist
From 3.0.0 · fixed in 3.4.26
- symfony/symfonyPackagist
From 4.0.0 · fixed in 4.1.12
- symfony/symfonyPackagist
From 4.2.0 · fixed in 4.2.7