CVE-2019-10909GHSA-G996-Q5R8-W7G2
In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, validation messages are not esc
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.7.51, 2.8.50, 3.4.26, 4.1.12, 4.2.7, and 2 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub
Summary
In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, validation messages are not escaped, which can lead to XSS when user input is included. This is related to symfony/framework-bundle.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- symfony/symfonyPackagist
From 2.7.0 · fixed in 2.7.51
- symfony/symfonyPackagist
From 2.8.0 · fixed in 2.8.50
- symfony/symfonyPackagist
From 3.0.0 · fixed in 3.4.26
- symfony/symfonyPackagist
From 4.0.0 · fixed in 4.1.12
- symfony/symfonyPackagist
From 4.2.0 · fixed in 4.2.7
- symfony/framework-bundlePackagist
From 2.7.0 · fixed in 2.7.51
- symfony/framework-bundlePackagist
From 2.8.0 · fixed in 2.8.50
- symfony/framework-bundlePackagist
From 3.0.0 · fixed in 3.4.26
- symfony/framework-bundlePackagist
From 4.0.0 · fixed in 4.1.12
- symfony/framework-bundlePackagist
From 4.2.0 · fixed in 4.2.7
- drupal/corePackagist
From 8.0.0 · fixed in 8.5.15
- drupal/corePackagist
From 8.6.0 · fixed in 8.6.15
- drupal/drupalPackagist
From 8.0.0 · fixed in 8.5.15
- drupal/drupalPackagist
From 8.6.0 · fixed in 8.6.15